Pages

Sunday, June 24, 2012

.NET Framework options in K2 for Visual Studio 2010

K2 for Visual Studio 2010 is able to build Workflow processes utilizing the .NET Framework 3.5 as well as 4.0. There are a few considerations which are important of how K2 integrates with the .NET Frameworks 3.5 and 4.0

Depending on the toolset that you use to create your workflows the following rules will apply. Keep that in mind before you start building your worklfows

.NET 3.5 Framework
.NET 4.0 Framework
Visual Studio 2010
Visual Studio 2010
K2 Studio

K2 Designer for SharePoint


Considerations
  • Existing and new projects in K2 for Visual Studio 2010 will be able to use .NET 4.0
  • To make use of the .NET 4.0 Framework the K2 Server will have to be updated by adding the following key to the appSettings node of the K2HostServer.config
    <add key="netfxversion" value="v4.0.30319" />
  • Wizards using Workflow (WF) currently only supports .NET Framework 3 or 3.5

No comments:

Post a Comment